POP3 ja IMAP4 -tuki päättyy 1.5.2018

Vanhat ja monin tavoin turvattomat pop3 -ja imap4 -sähköpostiprotokollat lakkaavat toimimasta JAMKin O365-palvelussa 1.5.2018.

Käytännössä kaikki nykyaikaiset päätelaitteet postisovelluksineen tukevat uudempia menetelmiä (mm. Activesync). Mikäli et tiedä käyttäneesi mainittuja vanhoja menetelmiä, ei sinun tarvitse tehdä mitään.

Syitä muutokselle:

  1. POP/IMAP-protokollien käyttäjämäärä on vähäinen.
  2. Kumpikaan protokollista ei tue kaksivaiheista todentamista.
  3. Jos käyttäjä määrittelee käyttöön salaamattoman yhteyden (tavallinen POP3/IMAP), tunnukset ja salasanat liikkuvat verkossa turvattomasti selväkielisenä.
  4. POP3 ja IMAP sallivat ns. email proxy -palvelun käyttämisen ja se rikkoo JAMKin käyttoehtoja sallimalla salanojen tallentamisen kolmansien osapuolten palvelimille. Vaikka tämä olisikin käyttäjän näkökulmasta kätevää, ei ole turvallista sallia tunnusten tallentamista ulkoisten toimijoiden haltuun.
  5. Kumpikaan protokolla ei osaa välittää tietoa vanhenevasta salasanasta.